This syntax seems ugly to me, clunky, and as you said probably breaks existing code

This, to me, is less clear than current methods of generating an 'inf' which is the whole reason I proposed it

Cade Brown
Research Assistant @ ICL (Innovative Computing Laboratory)
Personal Email:
ICL/College Email:

On Fri, Sep 11, 2020 at 9:38 AM Ricky Teachey <> wrote:
On Fri, Sep 11, 2020 at 3:09 AM Random832 <> wrote:
On Fri, Sep 4, 2020, at 12:45, Cade Brown wrote:
> I am positing that Python should contain a constant (similar to True,
> False, None), called Infinity.

What if we created a new syntax [and used it for the repr] that is not currently a valid identifier?

something like "1.INF"

 This is out of the box and might be considered insane, but what about:

>>> INF#
>>> INF # this is a comment as usual
NameError: INF

But I suppose this would be considered a breaking change, since the text "INF#" probably exists in code somewhere.


"I've never met a Kentucky man who wasn't either thinking about going home or actually going home." - Happy Chandler

Python-ideas mailing list --
To unsubscribe send an email to
Message archived at
Code of Conduct: