I should really stay out of this (hundreds of messages and still bickering^Wbikeshedding :-), but I personally find strict=True *less* confusing than equal=True, both for zip() and for map(). If I didn't know what was going on, seeing equal=True would make me wonder about whether equality between the elements might be involved somehow.

On Sun, May 3, 2020 at 9:42 PM Christopher Barker <pythonchb@gmail.com> wrote:
On Sun, May 3, 2020 at 6:17 PM Steven D'Aprano <steve@pearwood.info> wrote:
> >     map(func, x, y, strict=True)  # ?
> >
> > Admittedly the word "strict" in the context of `map` would be rather
> > confusing.
> >
>
> This a really good argument for "equal" rather than "strict".

Sorry, I'm not seeing why this would be confusing for `map` but not
`zip`. And "equal" might suggest that x and y need to be equal.

of course it would be confusing for zip. I and others have been advocating for "equal" over "strict" for a whiie. this is yet another argument. Since I never liked "strict", I'm not sure I can argue why it might be more confusing or map than zip :-)

Perhaps "truncate" or even "trunc" is a better keyword than either
strict or equal. Not that I'm arguing for a keyword here.

But it wouldn't be truncating anything. If we want to be wordy, equal_length would do it -- but I wouldn't want to be that wordy.

-CHB



--
Christopher Barker, PhD

Python Language Consulting
  - Teaching
  - Scientific Software Development
  - Desktop GUI and Web Development
  - wxPython, numpy, scipy, Cython
_______________________________________________
Python-ideas mailing list -- python-ideas@python.org
To unsubscribe send an email to python-ideas-leave@python.org
https://mail.python.org/mailman3/lists/python-ideas.python.org/
Message archived at https://mail.python.org/archives/list/python-ideas@python.org/message/DK3PG4ITHWSSCN4S4KW5EDPEBP26OSXF/
Code of Conduct: http://python.org/psf/codeofconduct/


--
--Guido van Rossum (python.org/~guido)
Pronouns: he/him (why is my pronoun here?)