On Fri, Sep 15, 2017 at 08:03:32PM +0200, Jason H wrote:
But really, I've learned a few things along the way. Though nothing to convince me that I'm wrong or it's a bad idea. It's just not liked by the greybeards, which I can appreciate. "here's some new punk kid, get off my lawn!" type of mentality. Dunning-Kruger, etc.
"The Dunning–Kruger effect is a cognitive bias wherein persons of low ability suffer from illusory superiority, mistakenly assessing their cognitive ability as greater than it is. The cognitive bias of illusory superiority derives from the metacognitive inability of low-ability persons to recognize their own ineptitude." -- Wikipedia.
If you're attempting to win us over to your side, stating that we're too stupid to realise how dumb we are is NOT the right way to do so.
But since you've just taken the gloves off, and flung them right in our faces, perhaps you ought to take a long hard look in the mirror. You've been told that at least some of the changes you're asking for are off the table because they will break working code. And that is still not enough to convince you that they are a bad idea?
So these aliases will be nothing but lose-lose for everyone:
- those who have to maintain and document them - those who have to learn them - those who have to answer the question "what's the difference between list.append and list.join, they seem to do the same thing" - those who have to read them in others' code - and those who have to decide each time whether to spell it alist.join or alist.append.
We're going to continue to prefer a mixed interface where functions are used for some operations and methods for others, and if that upsets you then you should read this: