On Fri, Jun 8, 2018, 10:12 Randy Diaz firstname.lastname@example.org wrote:
I think that the keyword do would solve problems that occur when people want a simple way to run a command over an iterable but they dont want to store the data.
do print(x) for x in range(50)
this above command will not return anything and will just run the command that is underlined over a generator. thus running a command comprehension or do comprehension. this will stop people from using the list comprehension to run an iterable through a function when they dont want to return anything. ( Specifically if memory is something we would want to conserve, such as in multithreaded web applications. )
I would prefer some some syntax for consuming iterators in a general way, such as
* = (x for x in y)