Those functions, ``load`` and ``loads``, for better or worse, are a standard across many modules. Now that the standard has been established, it's good to stick with it. Good interface design needs to consider familiarity as well as what might be best without any history.

On Wed, Nov 27, 2019 at 12:24 PM Abdur-Rahmaan Janhangeer <> wrote:
Greetings list,

Using 3.7, in json module of the std lib there is json.load and json.loads . I gather json.loads is more used to convert string to dict structure. json.load might cause (it already causes) confusions.

Suggestion: Rename json.load() so as not to confuse with json.loads()


Abdur-Rahmaan Janhangeer
Python-ideas mailing list --
To unsubscribe send an email to
Message archived at
Code of Conduct: