June 18, 2018
12:47 a.m.
On Mon, Jun 18, 2018 at 9:28 AM, Greg Ewing <greg.ewing@canterbury.ac.nz> wrote:
Chris Angelico wrote:
kwargs.pop("some_key") could plausibly be spelled del kwargs["some_key"] if del were (like yield) upgraded to expression.
Except that "delete" is a really misleading name for such an operation!
Is it? It's removing one element from the dictionary. Is that really so misleading? ChrisA