
Feb. 25, 2015
9:12 a.m.
This idea is already casually mentioned, but sank deep into the threads of the discussion. Raise it up. Currently reprs of classes and functions look as:
int <class 'int'> int.from_bytes <built-in method from_bytes of type object at 0x826cf60> open <built-in function open> import collections collections.Counter <class 'collections.Counter'> collections.Counter.fromkeys <bound method Counter.fromkeys of <class 'collections.Counter'>> collections.namedtuple <function namedtuple at 0xb6fc4adc>
What if change default reprs of classes and functions to just full qualified name __module__ + '.' + __qualname__ (or just __qualname__ if __module__ is builtins)? This will look more neatly. And such reprs are evaluable.