Am 08.10.2012 21:15, schrieb Nick Coghlan:
My own current preference is to take "p.joinpath(q)" straight from path.py (https://github.com/jaraco/path.py/blob/master/path.py#L236).
I don't *love* joinpath as a name, I just don't actively dislike it the way I do the four presented options (and it has the virtue of the path.py precedent).
I dislike + and  because I find the result too surprising. If I'd be forced to choose between +, / and  then I would go for / as it looks kinda like a path.
+1 for p.joinpath(*args). It's really a must have feature. The name is debatable, though.
+0 for p / sub
-1 for p + sub and p[sub]