On Mon, Apr 27, 2020 at 09:21:41AM -0700, Andrew Barnert wrote:
But this doesn’t do what the OP suggested; it’s a completely different proposal. They wanted to write this:
zipped = zip(xs, ys).skip()
… and you’re offering this:
zipped = zip.skip(xs, ys)
That’s a decent proposal—arguably better than the one being discussed—but it’s definitely not the same one.
So he did. I misread his comment, sorry. Perhaps I read it as I would have written it rather than as he wrote it :-( [...]
Your design looks like a pretty good one at least at first glance, and I think you should propose it seriously. You should be showing why it’s better than adding methods to zip objects—and also better than adding more functions to itertools or builtins, or flags to zip, or doing nothing—not pretending it’s the same as one of those other proposals and then trying to defend that other proposal by confusing the problems with it.
Last time I got volunteered into writing a PEP I wasn't in favour of, and (initially at least) thought I was writing to have the rejection reason documented, it ended up getting approved :-) -- Steven