Debian  (stretch) Linux OS
Using Anaconda3
pip and conda used for installations

I created profile_sfepy directory and content by running ipython profile create sfepy from the /root/.ipython directory. This created the subdirectory profile_sfepy in the .ipython directory. In the profile_sfepy directory, I then tried to edited the file as suggested in section 2.6 of the tutorial.

First problem:
  There is no c = get_config() line in the file. The unedited file is attached.
  exec_lines = [ ] does not exist. There is a:
  ## lines of code to run at IPython startup.
  #c.InteractiveShellApp.exec_lines = [ ] .
I put the exec_lines =  code directly into c.InteractiveShellApp.exec_lines "tuple?"
For the rest I found  places that fit.

When running ipython --profile=sfepy I got the following error:

ImportError: Matplotlib backend_wx and backend_wxagg require wxPython >=2.8.12
/root/anaconda3/lib/python3.5/site-packages/traits/etsconfig/ UserWarning: Environment variable "HOME" not set, setting home directory to /tmp
  (environment_variable, parent_directory))

I attempted to install wxpython with conda install wxpython  and got the following:
  UnsatisfiableError: The following specifications were found to be in conflict:
  - python 3.5*
  - wxpython

I ran conda info wxpython and found that wxpython depends on python 2.7. I use python 3.5 or 6 exculsively.

pip can't find the wxpython at all.

What now?


Gary R.