After normal inplace build process (ubuntu 12.04 64bit, Anaconda+python 2.7.9) I run testing and got one failure in module test_mesh_smoothing.py
Here is the output of the command:
% test_mesh_smoothing.py
<<< directory: tests, test files: 1
<<< tests/test_mesh_smoothing.py
sfepy: left over: ['verbose', '__builtins__', '_filename', '__file__', 'get_volume', '__package__', '__doc__', '__name__', 'TestCommon', 'op']
>>> test instance prepared (1 test(s))
sfepy: reading mesh [line2, tri3, quad4, tetra4, hexa8] (/home/rpezer/Software/sfepy/meshes/3d/cylinder.vtk)...
sfepy: ...done in 0.02 s
>>> <type 'exceptions.AttributeError'>
Traceback (most recent call last):
  File "run_tests.py", line 206, in <module>
    main()
  File "run_tests.py", line 197, in main
    run_tests(stats, dirname, [filename])
  File "run_tests.py", line 131, in run_tests
    n_fail, n_total, test_time = run_test(conf_name, options)
  File "run_tests.py", line 99, in run_test
    ok, n_fail, n_total = test.run(options.debug)
  File "/home/rpezer/Software/sfepy/sfepy/base/testing.py", line 58, in run
    ret = test_method()
  File "/home/rpezer/Software/sfepy/tests/test_mesh_smoothing.py", line 45, in test_mesh_smoothing
    vol0 = get_volume(conn, mesh.coors)
  File "/home/rpezer/Software/sfepy/tests/test_mesh_smoothing.py", line 26, in get_volume
    vols = mul * dets_fast(mtx.copy())
  File "/home/rpezer/Software/sfepy/sfepy/linalg/utils.py", line 80, in dets_fast
    lapack_routine = lapack_lite.dgetrf
AttributeError: 'module' object has no attribute 'dgetrf'

I checked the file sfepy/linalg/utils.py and found out that numpy 1.9.2 [MKL]
lapack_lite really has no dgetrf (older version do have) attribute. It seems to me easy to fix but maybe I am too naive. Any suggestions?