Hi Robert,

I upgraded to Windows10 and was able to build SfePy in place using
Visual C++ 2008 64-bit Command Prompt. Thanks for your help.

I have one more issue. I would like to install SfePy and not just use it in
place. While in the SfePy root directory after running

`python setup.py build_ext --inplace`

I don't get any errors, but outside of the SfePy root directory after running

`python setup.py build`

I get an error with the trace back listed below. Any thoughts on how to
fix this?

Thanks,

David

Python 2.7.11 |Anaconda custom (64-bit)| (default, Feb 16 2016, 09:58:36) [MSC v.1500 64 bit (AMD64)]
Type "copyright", "credits" or "license" for more information.

IPython 4.1.2 -- An enhanced Interactive Python.
?         -> Introduction and overview of IPython's features.
%quickref -> Quick reference.
help      -> Python's own help system.
object?   -> Details about 'object', use 'object??' for extra details.

In [1]: from sfepy.discrete.fem import Field
---------------------------------------------------------------------------
ValueError                                Traceback (most recent call last)
<ipython-input-1-afdfc336b24f> in <module>()
----> 1 from sfepy.discrete.fem import Field

C:\Users\Default.Default-PC\Anaconda2\lib\site-packages\sfepy-2016.1_git_ec8f05440577a054f5d139251f8f997703f72b23-py2.7-win-amd64.egg\sfepy\discrete\__init__.py in <module>()
      6 from functions import Functions, Function
      7 from conditions import Conditions
----> 8 from variables import Variables, Variable, FieldVariable, create_adof_conns
      9 from materials import Materials, Material
     10 from equations import Equations, Equation

C:\Users\Default.Default-PC\Anaconda2\lib\site-packages\sfepy-2016.1_git_ec8f05440577a054f5d139251f8f997703f72b23-py2.7-win-amd64.egg\sfepy\discrete\variables.py in <module>()
     10                              output, OneTypeList, Container, Struct, basestr,
     11                              iter_dict_of_lists)
---> 12 import sfepy.linalg as la
     13 from sfepy.discrete.functions import Function
     14 from sfepy.discrete.conditions import get_condition_value

C:\Users\Default.Default-PC\Anaconda2\lib\site-packages\sfepy-2016.1_git_ec8f05440577a054f5d139251f8f997703f72b23-py2.7-win-amd64.egg\sfepy\linalg\__init__.py in <module>()
----> 1 from extmods.crcm import rcm, permute_in_place
      2 from sparse import *
      3 from utils import *
      4 from geometry import *
      5 from eigen import *

__init__.pxd in init sfepy.linalg.extmods.crcm (build\src.win-amd64-2.7\sfepy\linalg\extmods\crcm.c:4828)()

ValueError: numpy.dtype has the wrong size, try recompiling




On Friday, May 13, 2016 at 3:49:12 AM UTC-4, Robert Cimrman wrote:
Hi David,

On 05/13/2016 03:32 AM, David Brough wrote:
> Hi Robert,
>
> I tried completely removing the build/ directory, but it still didn't
> compile.
>
> Thanks,
>
>>> using first specification
>>>      Creating library
>>> build\temp.win-amd64-2.7\Release\sfepy\discrete\common\extmo
>>> ds\_fmfield.lib and object
>>> build\temp.win-amd64-2.7\Release\sfepy\discrete\commo
>>> n\extmods\_fmfield.exp
>>> _fmfield.obj : error LNK2019: unresolved external symbol __imp_free
>>> referenced i
>>> n function __pyx_pf_5numpy_7ndarray_2__releasebuffer__
>>> _fmfield.obj : error LNK2019: unresolved external symbol __imp_malloc
>>> referenced
>>>    in function __pyx_pf_5numpy_7ndarray___getbuffer__
>>> LINK : error LNK2001: unresolved external symbol _DllMainCRTStartup
>>> sfepy_common.lib(fmfield.obj) : error LNK2019: unresolved external
>> symbol

this is weird. The compilation succeeds but linking fails, and those symbols
are from numpy. Googling the error seems to suggest [1], that possibly numpy
was compiled with another compiler than that used for sfepy extension modules,
but I do not know how to help with the debugging.

BTW. what command line shell do you use for the build. The anaconda prompt, git
bash prompt, or? Maybe there are some problems with paths.

r.

PS: a colleague of mine had also a similar problem on W10, so I came another
day to his computer, tried the command myself and it worked. There are
mysteries in MS world :)

[1] https://github.com/scikit-learn/scikit-learn/issues/3566