Hi again!  After looking up "segfault" and "CSR matix", I decided the most straightforward thing for me to do was to go grab an earlier version of SciPy and install it on my computer.  I did not do any "cleaning" before installing.  I downloaded SciPy 0.13.3 and installed it.

run_tests.py checks out just fine now, so I imagine your idea concerning the buggy sparse matrix in newer versions of SciPy is correct.

I hope this helps!

Matt 

On Saturday, July 26, 2014 3:05:24 PM UTC-5, myoungeleg wrote:
I believe I have scipy 0.14.0-7 as I downloaded Pyton(x,y) 2.7.6.1 to acquire the necessary .py files in order to run SfePy!

Thanks for all of your assistance!  It is exciting to be involved with a python community.  I don't recall having this kind of support available when working in C.

:D

On Saturday, July 26, 2014 3:00:00 PM UTC-5, Robert Cimrman wrote:
On 07/26/2014 04:32 PM, myoungeleg wrote:
> Thank you for your reply.  I edited the base.py file to reflect what Ouyang
> had posted.  This definitely worked and now when I run, run_tests.py every
> tests seems to function normally with an OK output.

OK

> However, upon the run_tests.py routine encountering
> tests\test_input_stokes_slip_bc.py, python.exe stops working and causes the
> run_tests.py to stall and then eventually stop running after accepting the
> python.exe prompt.

Do you have scipy 0.14.0 or newer? We have discovered that its sparse matrix
code segfaults on this example (called by _get_edge_path() when requesting a
submatrix of a CSR matrix). Either the matrix sfepy provides is wrong (I doubt
that - it worked ok for a long time), or there is a bug in scipy sparse package.

We will debug more :)

r.

> I re-ran run_tests.py while monitoring my CPU usage and physical memory
> usage.  At the time of the python.exe failure the CPU usage was about 65%
> and the physical memory had about 1300 MB free.  I noticed while the
> various test routines were running that python.exe never used more than
> about 550 MB of memory.
>
> I imagine that python.exe throwing an error likely has more to do with my
> system than the test_input_stokes_slip_bc.py file.
>
> I have a 64 bit system I can try all of this on later,  that has more
> resources.
>
> Any suggestions on where to start troubleshooting?
>
> Thanks,
>
> Matt
>
> On Friday, July 25, 2014 2:02:38 AM UTC-5, Robert Cimrman wrote:
>>
>> Hello,
>>
>> see [1] - we have probably a fix, thanks to Ouyang.
>>
>> r.
>> [1] https://groups.google.com/forum/#!topic/sfepy-devel/GKcexGbS5ZY
>>
>> On 07/24/2014 05:35 AM, myoungeleg wrote:
>>> Hello,
>>>
>>> I have attempted to install SfePy and was able to use Git Bash in
>> Windows 7
>>> Pro 32-bit and followed the instructions listed under "
>>> Steps to get a working *SfePy* on Windows using Python(x,y)
>>> <http://sfepy.org/doc-devel/installation.html#table-of-contents>"
>>>
>>> Everything seemed nominal but upon running run_tests.py the program
>> replied
>>> with "79 test file(s) executed in 31.40 s, 63 failure(s) of 116
>> test(s)".
>>>    For one of the tests, test_volume.py, I received the output, "test
>>> instance creation failed".
>>>
>>> I attempted to run test_volume.py in debug mode as suggested on the
>> webpage
>>> above, but I receive a number of "Import by filename is not supported"
>>> prompts.
>>>
>>> I am not sure if I have explained what I am experiencing enough, but on
>> the
>>> basis of what i have provided, is there a way to solve this issue?
>>>    Additionally, is more information necessary to assist me in
>>> troubleshooting this problem?
>>>
>>> Thank you!
>>>
>>
>>
>