I tried mayavi 4.2 and that works. Enthought's package manager makes it pretty easy to go back and forth between the current (4.4) and (4.2) so it's a good workaround for the moment.

Dennis

On Wednesday, June 10, 2015 at 8:19:01 AM UTC-7, Robert Cimrman wrote:
Thanks, we will check it as soon as we get to installing the same mayavi
version. (Temporary workaround: try 4.1, where the post-processing works.)

r.

On 06/09/2015 09:55 PM, Dennis Perchak wrote:
> The mayavi2 command runs by itself just fine.
>
> The version is 4.4 Build 4
>
> Here's the rest of the traceback:
>
> AttributeError: 'AlgorithmOutput' object has no attribute 'update'
> 2015-06-09 09:57:07.522 Python[5324:4282982] modalSession has been exited
> prematurely - check for a reentrant call to endModalSession:
> sfepy: point scalars t at [ 0.  0.  0.]
> sfepy: range: -2.00e+00 2.00e+00 l2 norm range: 1.06e-02 2.00e+00
> Exception occurred in traits notification handler.
> Please check the log file for details.Exception occurred in traits
> notification handler for object:
> <mayavi.tools.mlab_scene_model.MlabSceneModel object at 0x128fd5ef0>,
> trait: activated, old value: <undefined>, new value: True
> Traceback (most recent call last):
>    File
> "/Users/dennis/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/traits/trait_notifiers.py",
> line 520, in _dispatch_change_event
>      self.dispatch( handler, *args )
>    File
> "/Users/dennis/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/traits/trait_notifiers.py",
> line 483, in dispatch
>      handler( *args )
>    File
> "/Users/dennis/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/sfepy/postprocess/viewer.py",
> line 1191, in _post_init
>      viewer.render_scene(self.scene, viewer.options)
>    File
> "/Users/dennis/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/sfepy/postprocess/viewer.py",
> line 668, in render_scene
>      self.build_mlab_pipeline(**options)
>    File
> "/Users/dennis/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/sfepy/postprocess/viewer.py",
> line 510, in build_mlab_pipeline
>      active = mlab.pipeline.set_active_attribute(source)
>    File
> "/Users/dennis/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/mayavi/tools/pipe_base.py",
> line 38, in the_function
>      factory = factory_class(*args, **kwargs)
>    File
> "/Users/dennis/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/mayavi/tools/pipe_base.py",
> line 163, in __init__
>      self.set(**traits)
>    File
> "/Users/dennis/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/mayavi/tools/pipe_base.py",
> line 180, in set
>      self._anytrait_changed(trait, value)
>    File
> "/Users/dennis/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/mayavi/tools/pipe_base.py",
> line 198, in _anytrait_changed
>      setattr(obj, components[-1], value)
>    File
> "/Users/dennis/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/mayavi/core/trait_defs.py",
> line 101, in set_value
>      value )
> TraitError: The 'point_vectors_name' trait of a SetActiveAttribute instance
> must be one of [], but a value of '' <type 'str'> was specified.
> ERROR:traits:Exception occurred in traits notification handler for object:
> <mayavi.tools.mlab_scene_model.MlabSceneModel object at 0x128fd5ef0>,
> trait: activated, old value: <undefined>, new value: True
> Traceback (most recent call last):
>    File
> "/Users/dennis/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/traits/trait_notifiers.py",
> line 520, in _dispatch_change_event
>      self.dispatch( handler, *args )
>    File
> "/Users/dennis/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/traits/trait_notifiers.py",
> line 483, in dispatch
>      handler( *args )
>
>
> Dennis
>
>
> On Tuesday, June 9, 2015 at 10:11:46 AM UTC-7, Dennis Perchak wrote:
>>
>> Hi,
>>
>>   I have the Enthought Canopy Python distribution and am new to using
>> SfePy. I was trying to work through the examples and had a problem with
>> viewing the results. The package manager in Canopy already has SfePy
>> Version 2014.4 Build 6. Whenever I try to use the Viewer to look at
>> results, I get:
>>
>> ERROR:mayavi.core.common:Exception
>> Traceback (most recent call last):
>>    File
>> "/Users/dennis/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/mayavi/core/source.py",
>> line 216, in _handle_children
>>      obj.start()
>>    File
>> "/Users/dennis/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/mayavi/core/filter.py",
>> line 108, in start
>>      self.update_pipeline()
>>    File
>> "/Users/dennis/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/mayavi/filters/set_active_attribute.py",
>> line 133, in update_pipeline
>>      self._update()
>>    File
>> "/Users/dennis/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/mayavi/filters/set_active_attribute.py",
>> line 149, in _update
>>      input.update()
>> AttributeError: 'AlgorithmOutput' object has no attribute 'update'
>>
>>
>> I have no idea what the problem is. It happens on my Mac (running
>> Yosemite) and also my Windows 7 machine.
>>
>> I would greatly appreciate any help with this.
>>
>> Thanks.
>>
>> Dennis
>>
>