I commented out all of the lines of the test__input_stokes_slip_bc.py file, except for pass.  If commenting out all of the lines besides pass seemed like a questionable idea, please forgive me as I am quite new to python.  I do have experience in C and C++ programming a front end for a pretty sophisticated suite of software tools dealing with signal analysis and processing.  This prior programming experience was from years ago.  I am trying to get back into programming, this time for simulations of physical systems.  Please be patient with my postings! Thank you!

Upon running run_tests.py with lines in test_input_stokes_slip_bc.py commented out, all of the other tests passed, except for (you guessed it), test_input_stokes_slip_bc.py.  I took away all of the comments and re executed run_tests.py, with the result that when run_tests.py makes it to test_input_stokes_slip_bc.py, python.exe stops working (windows prompt stating that python.exe has stopped working, check windows for solutions, blah blah blah).

I feel the above should isolate the problem to stokes_slip_bc.py.  I am looking into it now, but my beginner understanding of python may limit my ability to solve this.


On Saturday, July 26, 2014 9:32:01 AM UTC-5, myoungeleg wrote:
Thank you for your reply.  I edited the base.py file to reflect what Ouyang had posted.  This definitely worked and now when I run, run_tests.py every tests seems to function normally with an OK output.

However, upon the run_tests.py routine encountering tests\test_input_stokes_slip_bc.py, python.exe stops working and causes the run_tests.py to stall and then eventually stop running after accepting the python.exe prompt.

I re-ran run_tests.py while monitoring my CPU usage and physical memory usage.  At the time of the python.exe failure the CPU usage was about 65% and the physical memory had about 1300 MB free.  I noticed while the various test routines were running that python.exe never used more than about 550 MB of memory.

I imagine that python.exe throwing an error likely has more to do with my system than the test_input_stokes_slip_bc.py file.  

I have a 64 bit system I can try all of this on later,  that has more resources.  

Any suggestions on where to start troubleshooting?



On Friday, July 25, 2014 2:02:38 AM UTC-5, Robert Cimrman wrote:

see [1] - we have probably a fix, thanks to Ouyang.

[1] https://groups.google.com/forum/#!topic/sfepy-devel/GKcexGbS5ZY

On 07/24/2014 05:35 AM, myoungeleg wrote:
> Hello,
> I have attempted to install SfePy and was able to use Git Bash in Windows 7
> Pro 32-bit and followed the instructions listed under "
> Steps to get a working *SfePy* on Windows using Python(x,y)
> <http://sfepy.org/doc-devel/installation.html#table-of-contents>"
> Everything seemed nominal but upon running run_tests.py the program replied
> with "79 test file(s) executed in 31.40 s, 63 failure(s) of 116 test(s)".
>   For one of the tests, test_volume.py, I received the output, "test
> instance creation failed".
> I attempted to run test_volume.py in debug mode as suggested on the webpage
> above, but I receive a number of "Import by filename is not supported"
> prompts.
> I am not sure if I have explained what I am experiencing enough, but on the
> basis of what i have provided, is there a way to solve this issue?
>   Additionally, is more information necessary to assist me in
> troubleshooting this problem?
> Thank you!