Hi Robert,

just to close this thread: The installation on a Windows machine without Anaconda is working now.

The problem was to have matching versions of other packages (numpy, ...)


2017-11-03 21:56 GMT+01:00 Robert Cimrman <cimrman3@ntc.zcu.cz>:
Hi Kathrin,

On 11/03/2017 04:00 PM, Kathrin Sobe wrote:
Hi Robert,

until now I was running sfepy only on a Ubuntu machine. Today I did a installation on a Windows 7 64 bit machine.

How were you installing sfepy on Ubuntu?

Already the imports in my program end with errors, that are a bit weired. I boiled it down and tried the imports directly in my python shell:

from sfepy.discrete import Field

from .equations import Equations, Equation
from sfepy.discrete.common.extmods.cmesh import create_mesh_graph
ImportError: cannot import name create_mesh_graph

I tried that directly as well and it does not work. It seems to be some code compiled in C? Do I need to compile something or install some extensions?

Yes, you need to compile the extension modules, when installing from sfepy sources, see [1].

The easiest way of installing sfepy (especially on windows) is to use anaconda, see [2].


[1] http://sfepy.org/doc-devel/installation.html#installing-sfepy-from-sources
[2] http://sfepy.org/doc-devel/installation.html#notes-on-multi-platform-python-distributions
SfePy mailing list