On 09/03/2008, at 19:13, Brett Cannon wrote:
We have to files related to zip files: zipfile and zipimport. Should we bother to consolidate? The problem is the obvious names conflict with built-in type and a keyword, respectively. A possibility is:
zipfile -> zip.filer zipimport -> zip.importer
But I don't know if that is really an improvement. What do other people think?
Although both modules somehow work with zip files they do completely different thing. Better would be to put zipimport with the import machinery and zipfile with tar or something.
-- Leonardo Santagada