We should really have a more explicit version of this, like a classmethod, Deferred.fromCoroutine(), that makes more sense in terms of what context you need to use it in. (The naming here comes from asyncio.ensure_future, but that does have the somewhat more explicit loop.create_task to pair with it.)
-glyph