I believe that this changed behavior, which is to have N+1 bins, where the last item it the right bound of the last bin, was the default with a warning in Numpy 1.4, so the change should be essentially transparent for that.

I'm a +1 for this.

Britton

On Fri, Oct 15, 2010 at 3:30 PM, Matthew Turk <matthewturk@gmail.com> wrote:
Hi all,

I just got an email that numpy versions less than 1.5 can't compile on
PPC.  Normally I would just upgrade the install script, but version
1.5 of NumPy also brings with it a change in the behavior of
histogram.

http://mail.scipy.org/pipermail/numpy-discussion/2010-August/052522.html

The behavior is to change the bounds of the bins.

I wanted to ping the list before I upgrade to 1.5 in the install
script; if no one has any objections in the next, oh, 2 days or so,
I'll go ahead and do so.

Best,

Matt
_______________________________________________
Yt-dev mailing list
Yt-dev@lists.spacepope.org
http://lists.spacepope.org/listinfo.cgi/yt-dev-spacepope.org