As for accessing things via .grid[field], I am -1 on this since I don't really want to be thinking about grids. We could consider .fluid, but in general I think I am okay with continuing to keep fluids first class and particles separate from them. I am willing to be convinced otherwise.
I realized as soon as I sent it I didn't mean what I had written, but it wasn't important enough to send another email about. Yes, I agree that .grid is not what we want. I was thinking "we have .particles, so we should also use .grid for grid quantities like density." I think there are several reasons why we shouldn't make accessing particles different from fluid quantities, but we can chat about that in "person".
-- Stephen Skory email@example.com http://stephenskory.com/ 510.621.3687 (google voice)