Hi team
- With the recent addition of Python 3.11 to the set of versions we actively support, we now have five (3.7 to 3.11).
NEP 29 , to which yt complies, only requires supporting “at least two” different versions at any given point, and recommends dropping 3.7 after December 21 (2021 !).
- Many important dependencies (including numpy and matplotlib) are already requiring Python 3.8 or newer.
recent history indicates that Python 3.8 is by far the version yt is most downloaded with (via PyPI)

With all this considered, I believe it is now reasonable to propose dropping Python 3.7.
It’s probably okay that we keep providing binaries for it throughout the upcoming yt 4.1.x release series, but I would like to start requiring Python 3.8 starting with yt 4.2, assuming everyone’s okay with that.

Let me know if you have any questions or arguments against it.
If not, I’ll start working on a patch targeted to yt 4.2