Hi Matt,

The change you suggested solved the problem of
ad['DarkMatter', 'particle_mass']
ad['CenOstriker', 'particle_mass']

However, when I do:
ad['all', 'particle_mass']
I get the following:

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/Users/britton/Documents/work/yt/yt-x86_64/src/yt-hg/yt/data_objects/data_containers.py", line 189, in __getitem__
  File "/Users/britton/Documents/work/yt/yt-x86_64/src/yt-hg/yt/data_objects/data_containers.py", line 535, in get_data
    particles, self, self._current_chunk)
  File "/Users/britton/Documents/work/yt/yt-x86_64/src/yt-hg/yt/geometry/geometry_handler.py", line 507, in _read_particle_fields
  File "/Users/britton/Documents/work/yt/yt-x86_64/src/yt-hg/yt/utilities/io_handler.py", line 176, in _read_particle_selection
    rv[field_f][my_ind:my_ind + vals.shape[0],...] = vals
ValueError: could not broadcast input array from shape (4851) into shape (4361)

Additionally, if I do:
ad['io', 'particle_mass']
I get this (which I got before this change as well):
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/Users/britton/Documents/work/yt/yt-x86_64/src/yt-hg/yt/data_objects/data_containers.py", line 183, in __getitem__
    f = self._determine_fields(key)[0]
  File "/Users/britton/Documents/work/yt/yt-x86_64/src/yt-hg/yt/data_objects/data_containers.py", line 406, in _determine_fields
    raise YTFieldTypeNotFound(ftype)
yt.utilities.exceptions.YTFieldTypeNotFound: Could not find field 'io'.


On Mon, Dec 2, 2013 at 3:54 PM, Britton Smith <brittonsmith@gmail.com> wrote:
Thanks, Matt!  I'll check this now and do so it if looks like it's working right.


On Mon, Dec 2, 2013 at 3:52 PM, Matthew Turk <matthewturk@gmail.com> wrote:
Hey Britton,

I just dug into it briefly, and it looks like the particle types for
active particles are not being "set up" the way they ought to be.  I
think the issue is that particle_types_raw was not being set
correctly.  Adding this line:

        self.particle_types_raw = self.particle_types

on line 855 of enzo/data_structures.py fixed it for me.  Can you
double-check the values, compare "io" to "DarkMatter" (they should be
identical) and if that looks good to you, submit a PR?


On Mon, Dec 2, 2013 at 10:45 AM, Matthew Turk <matthewturk@gmail.com> wrote:
> Hi all,
> Since we've closed the final pull requests, I've now made the
> repository yt_analysis/yt-3.0 read-only.
> If you issue pull requests, please do make sure you issue them from a
> named branch to the same named branch; bitbucket seems keen on merging
> across branches lately.  :)
> -Matt
> On Thu, Nov 28, 2013 at 9:57 AM, Britton Smith <brittonsmith@gmail.com> wrote:
>> Hi all,
>> After some discussion on the dev mailing list, we've decided to unify
>> the repositories for yt-3.0 and yt.  It will still be located in a branch
>> called
>> yt-3.0 in that repository.  At some point in the near future the separate
>> yt-3.0 repository will become read-only.
>> This simply means that if you are using yt normally, from the repository
>> here:
>> http://bitbucket.org/yt_analysis/yt
>> you will be able to switch to the yt-3.0 branch more easily.  And, if
>> you currently have a fork of the repository yt-3.0, you'll need to
>> switch to using a fork of the main yt repository.  This is easy, just
>> fork the main yt repo (unless you already have!) and push your yt-3.0
>> changes there.
>> Just as it has always been, installing the "stable" and "development"
>> versions
>> from the install script will still only put you on the latest stable and
>> development
>> versions of yt-2.x.  Additionally, doing "yt update" will not accidentally
>> switch
>> you from one version to the other.
>> Happy Thanksgiving!
>> Britton and the yt development team
>> _______________________________________________
>> yt-dev mailing list
>> yt-dev@lists.spacepope.org
>> http://lists.spacepope.org/listinfo.cgi/yt-dev-spacepope.org
yt-dev mailing list