Issue #947: Consistent field naming for spherical and cylindrical fields (yt_analysis/yt)
New issue 947: Consistent field naming for spherical and cylindrical fields https://bitbucket.org/yt_analysis/yt/issue/947/consistent-field-naming-for-s... Cameron Hummels: The issue of consistent field naming came up in Pull Request #1308, and further discussion occurred on the yt development sprint for yt 3.1 on 12.2.14. Right now there are two somewhat inconsistent field naming schemes associated with non-cartesian position and velocity fields. In particles, we have these: *Cartesian* ``` #!python ('all', 'particle_position_x') ('all', 'particle_position_y') ('all', 'particle_position_z') ('all', 'particle_velocity_x') ('all', 'particle_velocity_y') ('all', 'particle_velocity_z') ``` *Spherical* ``` #!python (‘all’, ‘particle_spherical_position_phi’) (‘all’, ‘particle_spherical_position_radius’) (‘all’, ‘particle_spherical_position_theta’) (‘all’, ‘particle_spherical_velocity_phi’) (‘all’, ‘particle_spherical_velocity_radius’) (‘all’, ‘particle_spherical_velocity_theta’) ``` and (after PR #1308): *Cylindrical* ``` #!python (‘all’, ‘particle_cylindrical_position_z’) (‘all’, ‘particle_cylindrical_position_radius’) (‘all’, ‘particle_cylindrical_position_theta’) (‘all’, ‘particle_cylindrical_velocity_z’) (‘all’, ‘particle_cylindrical_velocity_radius’) (‘all’, ‘particle_cylindrical_velocity_theta’) ``` For gas fields, we have these: *Cartesian* ``` #!python (‘index’, ‘x’) (‘index’, ‘y’) (‘index’, ‘z’) (‘gas’, ‘velocity_x’) (‘gas’, ‘velocity_y’) (‘gas’, ‘velocity_z’) ``` *Spherical* ``` #!python (‘index’, ‘spherical_phi’) (‘index’, ‘spherical_r’) (‘index’, ‘spherical_theta’) (‘gas’, ‘radial_velocity’) (‘gas’, ‘radial_velocity_absolute’) (‘gas’, ‘tangential_velocity’) (‘gas’, ‘tangential_over_velocity_magnitude’) ``` *Cylindrical* ``` #!python (‘index’, ‘cylindrical_r’) (‘index’, ‘cylindrical_theta’) (‘index’, ‘cylindrical_z’) (‘gas’, ‘cylindrical_radial_velocity’) (‘gas’, ‘cylindrical_radial_velocity_absolute’) (‘gas’, ‘cylindrical_tangential_velocity’) (‘gas’, ‘cylindrical_tangential_velocity_absolute’) ``` I would like to propose that we make new spherical and cylindrical gas fields that follow a similar naming convention to the explicit form of the particle fields. To make sure we're backwards compatible, we can just make field aliases from the field names above to the new fields. Or in the case of 'tangential_velocity' (and 'cylindrical_tangential_velocity'), it can remain, since it seem like the superposition of phi_velocity and theta_velocity.
participants (1)
-
Cameron Hummels