
Hi all,
I've been trying to get the new HOP/FoF implementation to run on L7 and on Kraken. I have found a couple problems.
The easy one is when trying to statically link both EnzoHop.a and EnzoFOF.a, it complains because they share the same kdtree naming structure. FoF should have its function names that conflict with HOP changed. I'll get around to changing this sometime. For now, I doubt anyone is using it. Alternatively, if they are identical enough, it may be good to use just one set of kdtree code for both. Thoughts?
Second, halo_list.write_out() is obtaining the particle_velocity_* fields serially, because now those fields aren't read in in parallel before calling the halo finder. What is the best way to read that data in parallel too, but only when its needed?
_______________________________________________________ sskory@physics.ucsd.edu o__ Stephen Skory http://physics.ucsd.edu/~sskory/ _.>/ _Graduate Student ________________________________(_)_\(_)_______________

I'll get around to changing this sometime. For now, I doubt anyone is using it. Alternatively, if they are identical enough, it may be good to use just one set of kdtree code for both. Thoughts?
Would be okay, sure -- I wonder about the differences in the INTERSECT code. We can change the names of the functions too, so that would fix the conflicts between signatures.
Second, halo_list.write_out() is obtaining the particle_velocity_* fields serially, because now those fields aren't read in in parallel before calling the halo finder. What is the best way to read that data in parallel too, but only when its needed?
You could add a call to get_data([...]) on the source region in write_out, and then all the halos would already have their particles when each halo is queried.
-Matt

I decided to just change all the function name in FOF. There were enough subtle changes that it wasn't worth trying to reconcile them. I've also attempted to remove that temporary file in hop_regroup.c that I had set to a random integer. Now it writes to a few arrays. I've done some tests and the hop changes seem to work fine.
Below are my changes, if there are no comments, I'll commit them sometime tomorrow (monday).
http://codereview.appspot.com/52058
The changes in HaloFinding.py at line 172 are a mistake. _______________________________________________________ sskory@physics.ucsd.edu o__ Stephen Skory http://physics.ucsd.edu/~sskory/ _.>/ _Graduate Student ________________________________(_)_\(_)_______________
participants (2)
-
Matthew Turk
-
Stephen Skory