I submitted this PR earlier today:
which provides a wrapper to SlicePlot that removes the "axis" argument and plots 2D datasets only.
Since it’s a function, we probably ought to give it a function-like name (all-lowercase with underscores to separate words), as Nathan has suggested. Something like plot_2d.
Any other ideas for a name?