Hi Alex,

Did you make sure to run the apt-get command the script prints out before installation begins? It looks like you might be missing some of the packages yt requires. When you first run the install script, it should print something like:

Looks like you're on an Ubuntu-compatible machine.

You need to have these packages installed:

  * libssl-dev
  * build-essential
  * libncurses5
  * libncurses5-dev
  * zip
  * uuid-dev
  * libfreetype6-dev
  * tk-dev

You can accomplish this by executing:

$ sudo apt-get install libssl-dev build-essential libncurses5 libncurses5-dev zip uuid-dev libfreetype6-dev tk-dev


If you haven't run that apt-get command, that would explain the error you're seeing.

Jeff



On Thu, Jul 30, 2015 at 11:12 AM alex volioths <alex-volos@hotmail.com> wrote:
Hello everyone,

I have just learned about yt and I'd like to try it out.
 I tried to install it using the shell script but i got the following error:
I am using Ubuntu 14.04 64 bit.

Installing pip
********************************************
        FAILURE REPORT:
********************************************

    bootstrap(tmpdir=tmpdir)
  File "get-pip.py", line 82, in bootstrap
    import pip
  File "/tmp/tmp4MGuKb/pip.zip/pip/__init__.py", line 15, in <module>
  File "/tmp/tmp4MGuKb/pip.zip/pip/vcs/subversion.py", line 9, in <module>
  File "/tmp/tmp4MGuKb/pip.zip/pip/index.py", line 30, in <module>
  File "/tmp/tmp4MGuKb/pip.zip/pip/wheel.py", line 35, in <module>
  File "/tmp/tmp4MGuKb/pip.zip/pip/_vendor/distlib/scripts.py", line 14, in <module>
  File "/tmp/tmp4MGuKb/pip.zip/pip/_vendor/distlib/compat.py", line 31, in <module>
ImportError: cannot import name HTTPSHandler

I have also attached the last lines from the log file.

Does anyone knows how can this error be fixed?

Thank you
Alex

_______________________________________________
yt-users mailing list
yt-users@lists.spacepope.org
http://lists.spacepope.org/listinfo.cgi/yt-users-spacepope.org