This still seems to be an issue.  Could someone just try running the latest install script on kraken to see if they get the same error?


On Tue, Apr 19, 2011 at 11:20 PM, Britton Smith <> wrote:
Hi everyone,

I just tried a new install of yt on kraken form the install script.  It failed on installing h5py 1.3 with the following error:

Configure: Autodetecting HDF5 settings...
    Custom HDF5 dir:       /lustre/scratch/britton/local-dev
    Custom API level:      None
/opt/cray/xt-asyncpe/4.0/bin/cc: INFO: linux target is being used
/opt/cray/xt-asyncpe/4.0/bin/cc: INFO: linux target is being used
/lustre/scratch/britton/local-dev/lib/libhdf5.a(H5Zdeflate.o): In function `H5Z_filter_deflate':
H5Zdeflate.c:(.text+0x134): undefined reference to `compress2'
H5Zdeflate.c:(.text+0x1ee): undefined reference to `inflateInit_'
H5Zdeflate.c:(.text+0x209): undefined reference to `inflate'
H5Zdeflate.c:(.text+0x270): undefined reference to `inflateEnd'
H5Zdeflate.c:(.text+0x3de): undefined reference to `inflateEnd'
H5Zdeflate.c:(.text+0x410): undefined reference to `inflateEnd'
/usr/bin/ld: link errors found, deleting executable `detect/vers'
collect2: ld returned 1 exit status

    Failed to compile HDF5 test program.  Please check to make sure:

    * You have a C compiler installed
    * A development version of Python is installed (including header files)
    * A development version of HDF5 is installed (including header files)
    * If HDF5 is not in a default location, supply the argument --hdf5=<path>
error: command 'cc' failed with exit status 1

I checked that the kraken yt install from the yt module is using h5py 1.2, which I believe suffers from the h5py bug that was mentioned not too long ago.  I double checked that I had gnu compiler module loaded, so I don't think that's it.  Does anyone have any ideas?