The other problem is that XSPEC doesn't do 64-bit builds on Mac because of X11, or so they say. If you can get it to work please let me know. I tried this earlier this week with no luck.

John ZuHone
Laboratory for High-Energy Astrophysics
NASA/Goddard Space Flight Center
8800 Greenbelt Rd., Code 662
Greenbelt, MD 20771
(w) 301-286-2531
(m) 773-758-0172

On Aug 24, 2012, at 5:02 PM, Eric Hallman <> wrote:


  thanks for the heads up.  I made the patch and am trying to rebuild.  Thanks!


Matt wrote:

Hi Eric,

Looks like this is known for non-framework builds of Python on OSX.

(We don't build it Framework-wise because it caused a bunch of

problems in the past and mainly only allowed usage of a few native

widgets.)  Here is a patch you can apply and then rebuild Python with

to (possibly) get it to work:


On Fri, Aug 24, 2012 at 4:46 PM, Eric Hallman <> wrote:


 I know this is not a yt specific issue, however it involves an interaction

of the yt installed python and XSPEC.  Maybe some of you on this list have

done an XSPEC install on Mac OS X (Lion in this case) and run into this.  At

link time during the build of XSPEC, it gives the following error:

Undefined symbols for architecture x86_64:

 "_environ", referenced from:

     _initposix in libpython2.7.a(posixmodule.o)

ld: symbol(s) not found for architecture x86_64

Originally on my Mac, XSPEC tried to build 32-bit, and failed with python

linkages (since python is 64 bit in the yt install build).  Once I went to

64-bit, this was the only remaining error.  Does anyone have ideas?


Eric Hallman


yt-users mailing list

yt-users mailing list