Hi Junhwan,

Unfortunately I don't have time to troubleshoot this at the moment.  The only idea I have is to try to install without setting DEST_DIR.  This will create a yt installation in the same folder the install script is invoked in.  The installation should be fully relocatable by moving the folder to a different location.  

In principle installation with a user-set DEST_DIR should work, but I doubt it's used all that often so it's possible an issue with it has crept in.

-Nathan


On Tue, May 13, 2014 at 1:04 PM, Junhwan Choi (최준환) <choi.junhwan@gmail.com> wrote:
Thank you Kacper.

However, I still get the same error message and fail to install yt.

Junhwan

On Tue, May 13, 2014 at 2:27 PM, Kacper Kowalik <xarthisius.kk@gmail.com> wrote:
> On 13.05.2014 17:13, Junhwan Choi (최준환) wrote:
>> Hi yt users,
>>
>> Recently, I try to install the yt on my mac desktop that uses OS X 10.8.4.
>> While installing yt, I face on strange error and fail to insall.
>> ........
>>     self._load()
>>   File "/Users/junhwan2/common/lib/python2.7/site-packages/mercurial/demandimport.py",
>> line 74, in _load
>>     mod = _hgextimport(_import, head, globals, locals, None, level)
>>   File "/Users/junhwan2/common/lib/python2.7/site-packages/mercurial/demandimport.py",
>> line 43, in _hgextimport
>>     return importfunc(name, globals, *args)
>> ImportError: dlopen(/Users/junhwan2/common/lib/python2.7/site-packages/mercurial/osutil.so,
>> 2): Symbol not found: __cg_png_create_info_struct
>>   Referenced from:
>> /System/Library/Frameworks/ImageIO.framework/Versions/A/ImageIO
>>   Expected in: /Users/junhwan2/common/lib/libPng.dylib
>>  in /System/Library/Frameworks/ImageIO.framework/Versions/A/ImageIO
>> /Users/junhwan2/common/bin/python2.7: can't open file
>> '/Users/junhwan2/common/src/yt-hg//distribute_setup.py': [Errno 2] No
>> such file or directory
>>
>> As far as I know, yt script needs to make src/yt-hg directory and cp
>> distribute_setup.py.
>> Hence, I can not understand what this error for.
>> Can anyone tell me how it happens and how I can fix it?
>>
>> FYI, I set DEST_DIR="/Users/junhwan2/common" in the script to install
>> yt in my home dir.
>>
>> Thank you in advance,
>> Junhwan Choi
>
> Hi Junhwan,
> could you try running:
>
> export DYLD_LIBRARY_PATH=.:/Users/junhwan2/common/lib/  (or unset it
> completely)
>
> and then running install script again. Cleaning previous installation
> would be also a good idea.
>
> Cheers,
> Kacper
>
>
>
>
> _______________________________________________
> yt-users mailing list
> yt-users@lists.spacepope.org
> http://lists.spacepope.org/listinfo.cgi/yt-users-spacepope.org
>
_______________________________________________
yt-users mailing list
yt-users@lists.spacepope.org
http://lists.spacepope.org/listinfo.cgi/yt-users-spacepope.org