Hi Stephanie,

Try running:

yt update --all

at the command line.  This will update the dependencies in addition to the yt codebase, and it may clear up your problems.


On Wed, Aug 28, 2013 at 12:55 PM, Stephanie Tonnesen <stonnes@gmail.com> wrote:
Dear all,

After a pretty long (few month) hiatus, I just tried to update my yt and seem to have broken it. 

Now my desktop is frozen so I can't cut and paste the long outputs, but it boils down to:

>yt update

The current version of the code is:

0be45301e0eb (yt) tip

This version CAN be automatically updated.

added 1740 changesets with 3520 changes to 355 files (+1 heads)
Updating the repository
126 files updates, 0 files merged, 0 files removed, 0 files unresolved
BROKEN:  See /u/stonnes/Installs/yt-x86_64/src/yt-hg/yt_updater.log

So I looked at that

and the first thing it had was:
pulling from https://bitbucket.org/yt_analysis/yt/
(run 'hg update' to get a working copy)

So I ran hg update and then it failed and said I had no module named write_array

When I start python2.7

and type
>> from yt.mods import *

I get the same error (no module write_array)

Any advice would be appreciated!



yt-users mailing list

Cameron Hummels
Postdoctoral Researcher
Steward Observatory
University of Arizona