Hi Nathan,

Got it. The problem was that the first parameter file I read in had the line AppendActiveParticleType = RadiationParticle.
The trouble was I put that in by hand as on restart I want that particle created. YT went looking for that particle in that output though and for some reason that was  OK in serial but caused problems in parallel (in a weird way too). Anyway if I comment that line out of the parameter file everything works.

John

On Fri, May 15, 2015 at 10:10 AM, John Regan <johnanthonyregan@gmail.com> wrote:
Hey,

Thanks. I'll start with your script and see if I can mine to behave. It is an Enzo 3.0 dataset and it also has extra baryon and RT fields as well so maybe that is doing something. Thanks!

John

On Fri, May 15, 2015 at 10:07 AM, Nathan Goldbaum <nathan12343@gmail.com> wrote:
I'm not able to reproduce this using the following test script:


Of course, given that it failed on line 200, your script is more complicated than mine.  Can you alter or expand on my test script to make a minimal example that fails?  You can get enzo_tiny_cosmology from yt-project.org/data, but it might be the case that your dataset has some features that trigger this issue.  

In particular, is this an Enzo 3.0 dataset?  I also tried with the ActiveParticleCosmology and wasn't able to reproduce the issue with that one either.

-Nathan

On Thu, May 14, 2015 at 11:56 PM, John Regan <johnanthonyregan@gmail.com> wrote:

On Fri, May 15, 2015 at 9:47 AM, Nathan Goldbaum <nathan12343@gmail.com> wrote:


On Thu, May 14, 2015 at 11:44 PM, John Regan <johnanthonyregan@gmail.com> wrote:
Hi All, 

I'm seeing an error when I run YT 3.2 in parallel. Running in serial mode everything is fine. I have a bunch of fields I'm creating profiles for 'DarkMatter' is not one of them but that's where it fails. It looks like its picking up the DarkMatter radius rather than the gas radius?


 rp = yt.create_profile(sphere, 'radius', Fields,
                               units = {'radius': 'kpc'},
                               n_bins=40)
P002 yt : [ERROR    ] 2015-05-14 22:09:54,308 YTFieldNotFound: Could not find field '('DarkMatter', 'radius')' in RD0001.

I've attached the error file

Looks like the pastebin is down, can you paste it somewhere else?
 

and the version info is:

---
Version = 3.2-dev
Changeset = 3e1887de7362+ (yt) tip
---

Thanks!

John

_______________________________________________
yt-users mailing list
yt-users@lists.spacepope.org
http://lists.spacepope.org/listinfo.cgi/yt-users-spacepope.org



_______________________________________________
yt-users mailing list
yt-users@lists.spacepope.org
http://lists.spacepope.org/listinfo.cgi/yt-users-spacepope.org



_______________________________________________
yt-users mailing list
yt-users@lists.spacepope.org
http://lists.spacepope.org/listinfo.cgi/yt-users-spacepope.org



_______________________________________________
yt-users mailing list
yt-users@lists.spacepope.org
http://lists.spacepope.org/listinfo.cgi/yt-users-spacepope.org