It’s almost certainly the case that you are running out of memory. You probably cannot load the entire snapshot at once on that machine using yt-3.x.

There is another wrinkle--the current stable version of yt will not properly support Arepo data. Since Arepo is definitely not traditional SPH, and yt-3.x assumes that scheme to map particle quantities to the octree, you will not get correct densities or other quantities mapped to the octree which yt creates for representing such data. That octree is also probably consuming a lot of memory and is probably contributing to your crash.

The next major version of yt, 4.0, is currently under development and has far better support for Lagrangian-based data in general, and support is being worked on for Arepo data as well, see this PR for instance:

If you’re interested in using the current yt 4.0 code for Arepo data, with all the usual caveats about versions like this being _highly_ unstable, I’d encourage you to check it out. You’ll need to clone yt from github and switch to the yt-4.0 branch:

git clone
cd yt
git checkout yt-4.0
pip install -e . 

You’d also need to use that branch from that PR I referenced earlier, though I am hoping we can get it merged into the 4.0 branch soon. 

Let us know if you’d like to pursue this further. 

On Jul 30, 2018, at 7:06 AM, Desika Narayanan <> wrote:


That's a lot of particles/octs.  Is there any chance you've run out of memory?   


On Mon, Jul 30, 2018 at 4:14 AM <> wrote:
I tried to use yt to analyse Illustris-1 data. However, yt can not load the data.
When I use the command
ds = yt.load("/scratch/Illustris/Illustris-1/snapdir_135/snap_135.0.hdf5")
I get this response
yt : [INFO     ] 2018-06-24 18:03:58,721 Calculating time from 1.000e+00 to be 4.340e+17 seconds
yt : [INFO     ] 2018-06-24 18:03:58,721 Assuming length units are in kpc/h (comoving)
yt : [INFO     ] 2018-06-24 18:03:58,803 Parameters: current_time              = 4.3395518355981376e+17 s
yt : [INFO     ] 2018-06-24 18:03:58,803 Parameters: domain_dimensions         = [2 2 2]
yt : [INFO     ] 2018-06-24 18:03:58,804 Parameters: domain_left_edge          = [0. 0. 0.]
yt : [INFO     ] 2018-06-24 18:03:58,804 Parameters: domain_right_edge         = [75000. 75000. 75000.]
yt : [INFO     ] 2018-06-24 18:03:58,804 Parameters: cosmological_simulation   = 1
yt : [INFO     ] 2018-06-24 18:03:58,804 Parameters: current_redshift          = 2.220446049250313e-16
yt : [INFO     ] 2018-06-24 18:03:58,804 Parameters: omega_lambda              = 0.7274
yt : [INFO     ] 2018-06-24 18:03:58,804 Parameters: omega_matter              = 0.2726
yt : [INFO     ] 2018-06-24 18:03:58,804 Parameters: hubble_constant           = 0.704
yt : [INFO     ] 2018-06-24 18:03:59,093 Allocating for 1.793e+10 particles (index particle type 'all')
yt : [INFO     ] 2018-06-24 19:53:51,036 Identified 7.700e+08 octs
/var/spool/pbs/mom_priv/jobs/306683.venus.SC: line 8: 185742 Segmentation fault      (core dumped)

What's wrong with yt?
yt-users mailing list --
To unsubscribe send an email to
yt-users mailing list --
To unsubscribe send an email to