Hello yt users,

I am having the exact same issues as was reported 1.5 years ago (see https://github.com/ytree-project/ytree/issues/44) in that ytree does not import because of yt.extern.six. I see this was resolved back then, but I am just now experiencing this issue. This happened after I installed yt 4.0.1. Here is my output:

>>>import ytree

/users/carla/.local/lib/python3.8/site-packages/yt/utilities/logger.py:4: VisibleDeprecationWarning: The configuration file /users/carla/.config/yt/ytrc is deprecated in favor of /users/carla/.config/yt/yt.toml. Currently, both are present. Please manually remove the deprecated one to silence this warning.

Deprecated since v4.0.0. This feature will be removed in v4.1.0

  from yt.config import ytcfg

>>> import ytree

Traceback (most recent call last):

  File "<stdin>", line 1, in <module>

  File "/opt/apps/pkgs/cpython/3.8.9/intel64/intel_2019.2/lib/python3.8/site-packages/ytree/__init__.py", line 16, in <module>

    from ytree.data_structures import \

  File "/opt/apps/pkgs/cpython/3.8.9/intel64/intel_2019.2/lib/python3.8/site-packages/ytree/data_structures/__init__.py", line 16, in <module>

    from ytree.data_structures.arbor import \

  File "/opt/apps/pkgs/cpython/3.8.9/intel64/intel_2019.2/lib/python3.8/site-packages/ytree/data_structures/arbor.py", line 23, in <module>

    from yt.extern.six import \

ModuleNotFoundError: No module named 'yt.extern'


Please let me know how I can get around this. 

Thanks in advance,
--
Carla Bernhardt
PhD Student
Universität Heidelberg
ZAH Institut für Theoretische Astrophysik