[AstroPy] pyfits - memory leak in new_table / 'hello, i am new here'

Martin Raue martin.raue at desy.de
Wed Jun 15 08:38:17 EDT 2011


Hi Stefan,

> I tried your script with revision 851 and the memory leak is there.
> Then I tried with trunk (currently 925) and there is no more memory leak.

Thanks for checking!

> 
> The problem you had with the installation happened to me as well, but it
> worked for me with:
> 
> sudo ./setup.py install
> 

Unfortunately, that produces the same error (also r925). Erik Bray wrote me that he will have a look at the installer.

In your case, it could be that your user and your superuser have different python version (and/or setups) installed or that /usr/bin/env points toward a different version of python then the python command.

Cheers, m

[uh2macastro04:~/tmp/trunk] $ sudo ./setup.py install
Downloading http://pypi.python.org/packages/source/d/distribute/distribute-0.6.15.tar.gz
Extracting in /tmp/tmpFIh03D
Now working in /tmp/tmpFIh03D/distribute-0.6.15
Building a Distribute egg in /Users/mraue/tmp/trunk
/Users/mraue/tmp/trunk/distribute-0.6.15-py2.6.egg
zip_safe flag not set; analyzing archive contents...

Installed /private/tmp/easy_install-l3cxoi/stsci.distutils-0.2dev-r13055/d2to1-0.1.5-py2.6.egg
zip_safe flag not set; analyzing archive contents...
stsci.__init__: module references __path__

Installed /Users/mraue/tmp/trunk/stsci.distutils-0.2dev_r13055-py2.6.egg
Searching for d2to1>=0.1.5
Reading http://pypi.python.org/simple/d2to1/
Best match: d2to1 0.1.5
Downloading http://pypi.python.org/packages/source/d/d2to1/d2to1-0.1.5.tar.gz#md5=34129f809b503449b283771b5c3f038b
Processing d2to1-0.1.5.tar.gz
Running d2to1-0.1.5/setup.py -q bdist_egg --dist-dir /tmp/easy_install-L6aIqn/d2to1-0.1.5/egg-dist-tmp-XIqk56
Traceback (most recent call last):
  File "./setup.py", line 33, in <module>
    use_2to3=True
  File "/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/core.py", line 113, in setup
    _setup_distribution = dist = klass(attrs)
  File "build/bdist.macosx-10.3-fat/egg/setuptools/dist.py", line 221, in __init__
  File "build/bdist.macosx-10.3-fat/egg/setuptools/dist.py", line 245, in fetch_build_eggs
  File "build/bdist.macosx-10.3-fat/egg/pkg_resources.py", line 544, in resolve
  File "build/bdist.macosx-10.3-fat/egg/pkg_resources.py", line 786, in best_match
  File "build/bdist.macosx-10.3-fat/egg/pkg_resources.py", line 798, in obtain
  File "build/bdist.macosx-10.3-fat/egg/setuptools/dist.py", line 293, in fetch_build_egg
  File "build/bdist.macosx-10.3-fat/egg/setuptools/command/easy_install.py", line 584, in easy_install
  File "build/bdist.macosx-10.3-fat/egg/setuptools/command/easy_install.py", line 614, in install_item
  File "build/bdist.macosx-10.3-fat/egg/setuptools/command/easy_install.py", line 804, in install_eggs
  File "build/bdist.macosx-10.3-fat/egg/setuptools/command/easy_install.py", line 1081, in build_and_install
  File "build/bdist.macosx-10.3-fat/egg/setuptools/command/easy_install.py", line 1070, in run_setup
  File "build/bdist.macosx-10.3-fat/egg/setuptools/sandbox.py", line 29, in run_setup
  File "build/bdist.macosx-10.3-fat/egg/setuptools/sandbox.py", line 70, in run
  File "build/bdist.macosx-10.3-fat/egg/setuptools/sandbox.py", line 31, in <lambda>
  File "setup.py", line 21, in <module>
    except ImportError:
  File "/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/core.py", line 152, in setup
    dist.run_commands()
  File "/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/dist.py", line 975, in run_commands
    self.run_command(cmd)
  File "/private/tmp/easy_install-l3cxoi/stsci.distutils-0.2dev-r13055/d2to1-0.1.5-py2.6.egg/d2to1/core.py", line 111, in run_command
AttributeError: 'NoneType' object has no attribute 'info'
[uh2macastro04:~/tmp/trunk] $ 

-----------------------------------

Martin Raue

University of Hamburg
Institute for Experimental Physics
Luruper Chaussee 149
D-22761 Hamburg
Germany

Phone  : +49-40-8998-5216
Fax    : +49-40-8998-2170
E-Mail : martin.raue at desy.de






More information about the AstroPy mailing list