[AstroPy] photometry in pyraf

Joe Philip Ninan indiajoe at gmail.com
Tue Jan 10 01:59:05 EST 2012

Hi Chris,
Taro's suggestion worked for me.
I anyway required a terminal version of epar. So tpar will be quite useful
for me.
Thanks a lot.

On 10 January 2012 02:37, Chris Sontag <sontag at stsci.edu> wrote:

>  Hi Joe,
> If Taro's suggestion isn't working for you, let me know off list.  There
> are a few different options to get this to work the way you need.
> And if there is a bug (or "unexpected feature"), we'd like to fix it.
> Finally, I believe we can get EPAR to do what you want, but to answer your
> question about a non-GUI version, yes, you can try "tpar" in PyRAF, for a
> terminal version (it requires the "urwid" package).
> Chris
> On 1/7/12 2:23 AM, Joe Philip Ninan wrote:
> Hi,
> I have been recently rewriting to pyraf all my photometry iraf scripts.
> For using the daofind and then phot task in noan.digiphot.daophot we
> first have to set the parameter files.
> Following is that section from my code.
> #--------------------(all the variables fwhm psfradi sigma datamin
> aperture etc. have been defined before in code)---------
>     iraf.daopar(matchra=fwhm, psfrad=psfradi, fitrad=fwhm)
>     iraf.datapar(fwhmpsf=fwhm, sigma=sigma, datamin=datamin,
> datamax=65000 , readnoi=4.8 , epadu=1.22 ,itime=intime,
> ifilter=filterr)
>     iraf.fitskypar(annulus=270, dannulu=12 )
>     iraf.photpar(apertur=aperture)
>     iraf.daofind(image=img)
>     #Going forward to do phot
>     iraf.phot(image=img)
> #----------------------------------------------------
> Now , when I run this code. It does displays the epar daopar, datapar
> etc in the GUI epar window of the pyraf with all correct values set.
> But when I press "Save & Quit" button and reaches the daofind or phot
> task. It is executing without all the seted parameters.
> It looks like inspite of me clicking on "Save & Quit" button. It is
> not getting saved. and the phot and daofind task are using some
> default setting in my uparm/
> In iraf, I had the same problem if i gave :wq in epar. But if I gave
> :w and then :q separately it used to work.
> There is no :w equivalent button in pyraf's GUI epar window.
> Can somebody point out some workaround for this problem? Is it
> possible in pyraf to get the non GUI epar window of iraf?
> Thanking you
> Joe
> --
> /-----------------------------------------------------------
> ----
> "GNU/Linux: because a PC is a terrible thing to waste" -  GNU Generation
> _______________________________________________
> AstroPy mailing listAstroPy at scipy.orghttp://mail.scipy.org/mailman/listinfo/astropy

"GNU/Linux: because a PC is a terrible thing to waste" -  GNU Generation

Joe Philip Ninan    http://sites.google.com/site/jpninan/
Research Scholar        /________________\
DAA,                            | Vadakeparambil |
TIFR,                           | Pullad P.O.         |
Mumbai-05, India.      | Kerala, India      |
Ph: +917738438212   | PIN:689548       |
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/astropy/attachments/20120110/0aba46b0/attachment.html>

More information about the AstroPy mailing list