[BangPypers] Trouble installing psycopg2 in Snow Leopard

Diptanu Choudhury admin.nitjece at gmail.com
Tue Feb 9 17:07:57 CET 2010


Hi All,

I am trying to use the psycopg2 library to connect to Postgres database.
However, on importing psycopg2, I get the following error.

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/Library/Python/2.6/site-packages/psycopg2/__init__.py", line 60, in
<module>
    from psycopg2._psycopg import BINARY, NUMBER, STRING, DATETIME, ROWID
ImportError: dlopen(/Library/Python/2.6/site-packages/psycopg2/_psycopg.so,
2): Symbol not found: _PQbackendPID
  Referenced from: /Library/Python/2.6/site-packages/psycopg2/_psycopg.so
  Expected in: flat namespace
 in /Library/Python/2.6/site-packages/psycopg2/_psycopg.so

The various software versions that I have on my system are -

Python 2.6.1
PostGres 8.4
psycopg2-2.0.13

I have tried installing libpqxx on my system too. Can some one help me with
this??

-- 
Thanks,
Diptanu Choudhury
Just a Coder, ThoughtWorks India
Mobile - 09886760964
Web - www.linkedin.com/in/diptanu


More information about the BangPypers mailing list