[BangPypers] Django porting app to multiple databases

s|s supr.e.etsethi at gmail.com
Fri Mar 2 19:17:00 CET 2012


On Fri, Mar 2, 2012 at 3:06 PM, Amit Sethi <amit.pureenergy at gmail.com>wrote:

> Hi all , My app has started breaking after moving to django 1.3 . I
> don't really understand why?
>
> I am working  using site framework and given model definition through
> app_label. The only major change as I can see is that I use UUID
> Fields rather than AutoField. Now somehow i see that my app is trying
> to make a connection to some other db essentially.
>
> ConnectionDoesNotExist: The connection myapp doesn't exist
>
> myapp here is one of applications in my site famework and the model
> definations are given as
>
>
>
>From my understanding the database is not getting connected. Try modifying
the settings for database details.


> myapp/
>        __init__.py
>        Circle.py
>        Square.py
>
> where Circle and Square are the different models ... Can someone tell
> me how this came out ...
>
> I checked again by moving the back to 1.1 and it works like a charm
> ... Interesting while I have given defination of one more database in
> my settings ... I am not actually using it anywhere as yet...
>
> So essentially my question why has django started to look for a new
> database suddenly.
>
>
>
>
>
> Thanks
> Amit
>
> --
> A-M-I-T S|S
> _______________________________________________
> BangPypers mailing list
> BangPypers at python.org
> http://mail.python.org/mailman/listinfo/bangpypers
>



-- 
Supreet Sethi
Ph UK: +447859172473
Ph IN: +919811143517
Ph Skype: d_j_i_n_n
Profile: http://www.google.com/profiles/supreet.sethi
Twt: http://twitter.com/djinn


More information about the BangPypers mailing list