[Baypiggies] padding variable assignments, why is it bad?

Aleksandr Miroslav alexmiroslav at gmail.com
Fri Aug 10 19:19:21 CEST 2012


(Reading this email requires a monospaced font.)

I do this a lot in my code:

    foo          = 1
    foo_bar      = 2
    foo_bar_quux = 3

but pep8, which I started using recently, considers this wrong, so I
have to rewrite to the more common form:

    foo = 1
    foo_bar = 2
    foo_bar_quux = 3

which I think sacrifices readability. Perhaps this is the n00b in me
talking, but why is this considered bad?


More information about the Baypiggies mailing list