[Baypiggies] padding variable assignments, why is it bad?

Nam Nguyen bitsink at gmail.com
Fri Aug 10 19:38:17 CEST 2012


PEP 8 also says (quoted as-is, with original misspellings):

    When in doubt, use your best judgment

So, it's okay if you find that spaces help you in reading code. Make
sure to keep it consistent in the same module.

Nam


On Fri, Aug 10, 2012 at 10:19 AM, Aleksandr Miroslav
<alexmiroslav at gmail.com> wrote:
> (Reading this email requires a monospaced font.)
>
> I do this a lot in my code:
>
>     foo          = 1
>     foo_bar      = 2
>     foo_bar_quux = 3
>
> but pep8, which I started using recently, considers this wrong, so I
> have to rewrite to the more common form:
>
>     foo = 1
>     foo_bar = 2
>     foo_bar_quux = 3
>
> which I think sacrifices readability. Perhaps this is the n00b in me
> talking, but why is this considered bad?
> _______________________________________________
> Baypiggies mailing list
> Baypiggies at python.org
> To change your subscription options or unsubscribe:
> http://mail.python.org/mailman/listinfo/baypiggies


More information about the Baypiggies mailing list