[Baypiggies] padding variable assignments, why is it bad?

Aahz aahz at pythoncraft.com
Sat Aug 11 00:27:41 CEST 2012


On Fri, Aug 10, 2012, Aleksandr Miroslav wrote:
> 
> I do this a lot in my code:
> 
>     foo          = 1
>     foo_bar      = 2
>     foo_bar_quux = 3
> 
> but pep8, which I started using recently, considers this wrong, so I
> have to rewrite to the more common form:
> 
>     foo = 1
>     foo_bar = 2
>     foo_bar_quux = 3
> 
> which I think sacrifices readability. Perhaps this is the n00b in me
> talking, but why is this considered bad?

You're promoting a tactical view of code readability rather than
strategic.  I find this style much more difficult to read over larger
blocks of code with multiple levels of indentation.
-- 
Aahz (aahz at pythoncraft.com)           <*>         http://www.pythoncraft.com/

The difference between "intelligence" and "wisdom": Londo and G'Kar  


More information about the Baypiggies mailing list