[Catalog-sig] PyPI permissions are broken: cannot manage packages I own

Gary Poster gary.poster at canonical.com
Mon Aug 31 23:26:56 CEST 2009


On Aug 31, 2009, at 9:56 AM, Gary Poster wrote:

> Trying to manage package details for packages I own is broken.  I  
> tried with an old-style non-OpenID login and then linked my Google  
> OpenID and it failed again in the same way.
>
> More concretely, I log in; click on a link for one of the packages  
> on the right, for which I have privileges, such as http://pypi.python.org/pypi?%3Aaction=pkg_edit&name=lazr.uri 
>  ; and get the following.
>
> Forbidden
>
> You are not allowed to edit 'lazr.uri' package information
>
> I'm currently going through the dance to be able to create a bug  
> report on sourceforge, but meanwhile I wanted to report here.

Martin, Sourceforge's tracker did not allow me to add another comment  
to confirm that everything worked after I cleared my pypi cookies  
there, so here I am.  It works now.  Thanks!

Gary


More information about the Catalog-SIG mailing list