[Catalog-sig] Problem uploading an MSI to PyPI

exarkun at twistedmatrix.com exarkun at twistedmatrix.com
Wed Apr 13 04:52:08 CEST 2011

Hello all,

A member of the Tahoe-LAFS community was kind enough to build a Python 
2.6 amd64 MSI installer for pyOpenSSL 0.12 for me (since I am not set up 
to build anything for 64 bit Windows).

The MSI is available at http://twistedmatrix.com/~exarkun/pyOpenSSL-0.12 
.win-amd64-py2.6.msi for the time being.  It might be interesting to 
inspect in considering the question I have.

First I tried uploading it to PyPI using the web interface. 
Unfortunately this resulted in a failed upload (several times) because 
"invalid distribution file".

Then I tried using the distutils upload command (which I had to modify 
to allow uploading a file which was already built, rather than one which 
was being built at the moment).  This produced the same result ("Upload 
failed (400): invalid distribution file").

So... is this a distutils bug?  Is there something wrong with the MSI? 
Is it something wrong with pyOpenSSL's setup.py?  Is it a bug in PyPI 
causing it to reject a valid MSI?

(I hope the cross-posting is okay, since this topic seems to straddle 
these two areas.)


More information about the Catalog-SIG mailing list