[Catalog-sig] trove - LGPL v3 not recognised?

Richard Jones richard at python.org
Mon Jan 30 01:41:31 CET 2012


On 30 January 2012 11:27, Robert Collins <robertc at robertcollins.net> wrote:
> On Mon, Dec 12, 2011 at 6:41 AM, Robert Collins
> <robertc at robertcollins.net> wrote:
>> These are the ones I would like to see:
>>
>>> >License :: OSI Approved :: GNU Lesser General Public License v2 (LGPLv2)
>>> >License :: OSI Approved :: GNU Lesser General Public License v3 (LGPLv3)
>>> >License :: OSI Approved :: GNU Lesser General Public License v2 or later (LGPLv2+)
>>> >License :: OSI Approved :: GNU Lesser General Public License v3 or later (LGPLv3+)
>>> >License :: OSI Approved :: GNU General Public License v2 (GPLv2)
>>> >License :: OSI Approved :: GNU General Public License v3 (GPLv3)
>>> >License :: OSI Approved :: GNU General Public License v2 or later (GPLv2+)
>>> >License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)
>>
>> Doing a 4th level would raise a bunch of interactions between legal
>> intent  - the above list seems like a good compromise. We've just had
>> a user turn up confused around this again, so - do we have sufficient
>> consensus to add these?
>>
>> -Rob
>
> Ping? I'm not sure how to check if these were added or not ?

The classifier list is available on PyPI via the "List trove
classifiers" sidebar link:
http://pypi.python.org/pypi?%3Aaction=list_classifiers

I've not been following the discussion closely so I'm not sure that a
consensus has been agreed upon (I'm guessing that the participants in
the November discussion went on vacation.)


     Richard


More information about the Catalog-SIG mailing list