[Catalog-sig] Dependencies

anatoly techtonik techtonik at gmail.com
Wed Jun 13 13:55:44 CEST 2012


I need to build Fabric RPM package for Fedora. I use py2pack to
generate .spec file, which in turn uses PyPI information for it. The
problem that PyPI completely misses information about dependencies. Is
that intentional, broken or just not implemented? Any previous
discussions/outcomes?

http://pypi.python.org/pypi/Fabric/json - here should be a reference
to ssh package dependency which is present in setup.py as:
    install_requires=['ssh>=1.7.14'],


P.S. My patch queue is still awaiting review comments at this changeset
        https://bitbucket.org/techtonik/pypi-techtonik/changeset/5396f8c60d49#comments
--
anatoly t.


More information about the Catalog-SIG mailing list