[CentralOH] Python 2.5.1 / Ubuntu 7.10 problem with .zip file

William McVey wam at cisco.com
Tue Mar 11 15:41:51 CET 2008

On Thu, 2008-03-06 at 13:22 -0500, Mark Erbaugh wrote:
> I've done most of the development with
> Python
> 2.4.3 under Ubuntu 6.06.  Today, I tried running the application
> under
> Python 2.5.1 with Ubuntu 7.10. It is unable to read either of
> the .zip
> files that the program uses for updates. 

Since this thread started on a public list, I think it's only fitting
that the resolution is shared for others. Mark and I figured out in a
side conversation that his problem was that his zip file had python
bytecode compiled for python 2.4. When he tried running his code under
python 2.5, it was able to open the zip just fine, it just wasn't able
to import binary modules compiled for the older interpreter. I believe
he is going to be doing version-specific zip files, as well as
researching eggs as a more standard way of shipping his updates.

  -- William

More information about the CentralOH mailing list