[Chicago] Install problems with numpy via pip on Snow Leopard (Mac OS X 10.6.x)

Skip Montanaro skip at pobox.com
Wed Feb 20 14:48:14 CET 2013


> do
>
> file /Users/skip/django/mysite/venv/lib/python2.7/site-packages/numpy/core/multiarray.so
>
> At least that will tell you what architecture the shared object was
> built for.

Thanks, Ken.  That was the clue.  I had run file against that and it
looked fine, however, I'd failed to run file against my Python
interpreter.  They don't match.  Looks like I have a 64-bit numpy and
32-bit Python:

(venv)mysite% file /Users/skip/django/mysite/venv/bin/python
/Users/skip/django/mysite/venv/bin/python: Mach-O executable i386
(venv)mysite% file
/Users/skip/django/mysite/venv/lib/python2.7/site-packages/numpy/core/multiarray.so
/Users/skip/django/mysite/venv/lib/python2.7/site-packages/numpy/core/multiarray.so:
Mach-O 64-bit bundle x86_64

So, it appears to be time to refresh my Python interpreter.  Is there
an easy way to update the Python install inside an existing
virtualenv?

Skip


More information about the Chicago mailing list