[code-quality] flake8 package versions

Kálmán Viktor kviktor at cloud.bme.hu
Wed Oct 7 14:43:27 CEST 2015


Hey,

are you guys planning to upgrade the pep8 and the pyflakes8 packages in 
flake8?
If I update them manually everything works great, see:

(xy)xy at xy:~$ flake8 --version
2.4.1 (pep8: 1.6.2, pyflakes: 1.0.0, mccabe: 0.3.1) CPython 3.4.0 on 
Linux

However if I uninstall flake8 and reinstall it (or simply upgrade an 
older version) then I get outdated versions of pep8 and pyflakes.

(xy)xy at xy:~$ flake8 --version
2.4.1 (pep8: 1.5.7, pyflakes: 0.8.1, mccabe: 0.3.1) CPython 3.4.0 on 
Linux



Regards,
Viktor


More information about the code-quality mailing list