[code-quality] FreeBSD installation of pylint3

Paul Hargreaves paul.hargreaves at technowizardry.co.uk
Mon Oct 12 23:03:15 CEST 2015


> $ python3.5 -m pip install pylint (and other packages)

$ python3.5 -m pip install pylint
python3.5: not found

Likely this is because BSD is still at 3.4:
$ python3 --version
Python 3.4.3

But skipping the full version doesn’t work either:
$ python3 -m pip install pylint
/usr/local/bin/python3: No module named pip
$ 

> Use “pip3” or “pip3.5” or whatever is more suitable instead of “pip”.

No instructions to use pip; http://pylint.org/#install  says
FreeBSD
portmaster devel/pylint


Which is what I did.
Didn’t have this problem on Linux, just on FreeBSD.


> On 12 Oct 2015, at 21:22, Ian Cordasco <graffatcolmingov at gmail.com> wrote:
> 
> On Mon, Oct 12, 2015 at 3:04 PM, Jeff Quast <contact at jeffquast.com> wrote:
>> The version of pip used matches the version of python it installs for.
>> 
>> Use “pip3” or “pip3.5” or whatever is more suitable instead of “pip”.
> 
> I've actually found it most reliable to do:
> 
> $ python3.5 -m pip install pylint (and other packages)
> _______________________________________________
> code-quality mailing list
> code-quality at python.org
> https://mail.python.org/mailman/listinfo/code-quality



More information about the code-quality mailing list