[C++-SIG] Re: Problems building and testing CXX demo

Phil Austin phil at geog.ubc.ca
Tue May 9 18:16:18 CEST 2000

Steve Harris writes:
 > Geoffrey Furnish <furnish at actel.com> writes:
 > [...]
 > > It looks to me like just a small problem with the invocation of the
 > > loader.  The KCC driver script may be able to notice that you've
 > > provided a library without using a library introducer token (-l), and
 > > perhaps g++ just isn't grokiing that in the version you're using.
 > > 
 > > Try changing your g++ invocation line to:
 > > 
 > > g++ python.o -o mypython -L ~/usr/local/lib/python1.5/config \
 > >   -lpython1.5 -lm -lnsl -lsocket -ldl -L. -lcxx
 > Thanks for the tip. Unfortunately, we're still without joy. I tried
 > that change and got the same error regarding the undefined symbol
 > "in."
 > I'm wondering if this is a problem with some unintended interaction
 > between Gnu and Sun tools.

one other thing you might check: are you able to build/run
Python-1.5.2/Demo/embed/demo.c with gcc?  That would at least
reassure you that you had the basic link sequence right.

Even if this works though, it doesn't solve your problem of
test() crashing when you import example.so -- so maybe the
next step is to install the March snapshot and reproduce
Marc Poinot's success with example.so, then tackle python.cxx.
I'd be interested in hearing if your compile time is reduced.

Regards, Phil

More information about the Cplusplus-sig mailing list