[C++-sig] more boost v1 problems

cseymour at interchange.ubc.ca cseymour at interchange.ubc.ca
Thu Aug 22 01:36:33 CEST 2002

Hello again,

sorry for posting about this again but i can't figure it out...
I had boost working yesterday, but today (the computer it was working on is fried) it refuses to work.

I'm using the linux gcc makefile. I've tried g++ 2.96 (which it worked with before) and python 2.2.1 compiled with g++ 2.96, and also g++ 3.0.4 and python 2.2.1 compiled with g++ 3.0.4 (which the boost python webpage says should work). in both cases, when running comprehensive.py it fails like so:

Running comprehensive.__doc__
    ext = Foo()
except TypeError, err:
    assert re.match(r'function .* exactly 1 argument;? \(?0 given\)?',
    print 'no exception'
Expecting: nothing

and i assume this is because of the ABI / exception handling problems. my extension modules seem to work, except when they try to throw exceptions.

the only difference i can think of between computers is that the computer I was working on before had glibc version 2.2.5 installed, while the rest have 2.2.4 (it was in changing glibc back that the computer died)

does anyone have any ideas on what i could do? again, sorry for sort of re-posting but i've worked at this and can't figure it out

More information about the Cplusplus-sig mailing list